読者です 読者をやめる 読者になる 読者になる

naichi's lab

3日後の自分(他人)への書き置き

MacにRabbitをインストールしようとしてエラー。.pc for libffi doesn't exist. (RuntimeError)

Error メモ

環境

  • Mac OSX Yosemite 10.10.5

Rabbitをインストールしようとした

  • Gemfile作って
  • gem "rabbit"
  • $ bundle install --path vendor/bundle
  • エラー

    .pc for libffi doesn't exist. (RuntimeError)

  • ここみて下記コマンド実行

    $ PKG_CONFIG_PATH=/usr/local/opt/libffi/lib/pkgconfig bundle update

  • $ bundle install --path vendor/bundle

成功っぽい